System requirements Minimum requirements for the current release version

Application server

Hardware:

  • Comparable Intel CPU of the families Skylake, Kaby Lake or Coffee Lake (min. 4 cores)
  • For each application instance
    • 6 GB RAM minimum, 10 GB recommended
    • 10 GB hard disk space, SSD recommended

Supported operating systems:

  • MS Windows Server 2019ac
  • MS Windows Server 2016ac
  • MS Windows Server 2012ac

Software:

  • Internet Information Services Version 8.5 or higher
  • .NET Framework Version 4.7.1 or higher

Database systems:

  • MS SQL Server 2017ade
  • MS SQL Server 2016ade
  • MS SQL Server 2014ade (in compatibility mode Server 2012)
  • MS SQL Server 2012ade
  • Oracle 11gad
  • Oracle 12cad

Additional per database:

  • Observe DB system requirements
  • Comparable Intel CPU of the families Skylake, Kaby Lake or Coffee Lake (min. 4 cores)
  • At least 16 GB RAM
  • 50GB hard disk space

Web-Client

Browser version:

  • Internet Explorer Version 11 or higher
  • Mozilla Firefox Version 58 or higher
  • Google Chrome Version 72 or higher
  • Apple Safari iOS Version 12 or higher
  • Microsoft Edge Version 44 or higher
  • Mobile clients can be operated via WLAN / mobile radio

Mobile device

Hardware:

  • Intel® Core i5-5300U vPro-Prozessor (2,3 GHz) or compareable
  • 4 GB RAM
  • 25 GB hard disk space for data and basic maps
  • 10“ display
  • Recommendation: Panasonic Toughpad FZ-G1
  • GPS sensor driver supporting Windows Location Service

Software:

  • .NET Framework Version 4.7.1 or higher
  • Windows 8.1d,f, Windows 10d,f

Mobil+ Solutions

  • ArcGIS for Server Standard 10.2.2 or higher (Workgroup or Enterprise)
  • Microsoft Visual C++ Redistributable für VS2017

Interface client for EasyConnect

Hardware:

  • Intel Core i5-5300U vPro-Prozessor (2,3GHz) or compareable
  • 4 GB RAM
  • 10 GB hard disk for installation and logging

Supported operating systems:

  • MS Windows Server 2012 or higher
  • MS Windows Windows 8.1 or higher

Software:

  • MS SQL-Server Compact Version 4.0 or higher
  • .NET-Framework Version 4.5.2 or higher

Hints:

  • Network connection to the application server must be available.
  • WCF services must be activated on the application server.
  • When using an Oracle database as data source, an Oracle 64Bit client must be installed.

Abbreviations:

a) Standard 
b) Datacenter (32-bit) 
c) Datacenter (64-bit) 
d) Enterprise 
e) Express
f) Professional